ArcheRage on Linux

Discussion in 'Off Topic' started by Lusk, Dec 31, 2018.

  1. Lusk

    Lusk Member

    Hello, I'm here again to ask if someone is playing archeRage on linux... If so, how can I run it?
    Wine? Play On Linux?
    Any tutorial to make this possible?
    ecolization likes this.
  2. vulgrr

    vulgrr Active Member

    You'll need to install the DirectX APIs first to run games on Wine.

    There's a tutorial there.

    Make note, you should grab the latest DirectX 9 redistributable. I don't think 9c is the latest.

    You'll also need the linux drivers for your specific GPU.

    Wine isn't the greatest platform for gaming, however. Some games may work OK, if they're not very demanding to begin with. Archeage, however, runs on the Crytek engine. Crytek is great at vomiting bloom in your face, but not much else. The engine isn't optimized for shit, and chugs even in simple areas at times (try visiting a castle area in auroria, for example. misery).

    It's been a really really long time since I've even touched Wine, so I forget a lot of other stuff, but I think with just DirectX installed, then launching the game with Wine should work.
  3. Lusk

    Lusk Member

    I almost played... I got this error when I open launcher:
    After I click Play nothing happens, sadly :/
  4. nzoth

    nzoth New Member

    Wine is always the answer, sadly not a perfect one.
    Try google (or other search engines, like duckduckgo ) for this.
    We need to spread the word to linux users.
  5. vulgrr

    vulgrr Active Member

    What does sem memoria mean? Closest translation I can find is "Salad memory"?? Makes no sense, in computer land
  6. Lusk

    Lusk Member

    Sorry, it's Portuguese.
    "Sem memória" = "No memory"
    There's no RAM available (?)
  7. nzoth

    nzoth New Member

    Check the game requirements, and search in google for problems of windows software running on wine with similar error messages
  8. vulgrr

    vulgrr Active Member

    I'll try to get a version of Linux up and running on a laptop I've got kicking around, and see if I can get this to work.

    There might be a need to configure Wine to allocate more memory in order to run the game, I'm unsure.

    In the mean time, after googling around, I found this. Run the below command in step 1, then navigate through the registry by following step 2.

    1. wine regedit
    2. go to:
      HKEY_CURRENT_USER → Software → Wine → Direct3D → VideoMemorySize
      and set the value to a higher one. The default seems to be 64Mb.
      If you see no such key, create it (right-click on Direct3D, select New then String Value and name it VideoMemorySize
  9. LuxurySmooth

    LuxurySmooth New Member

    Yoho! it indeed works if you are running it under dx9 (NINE ONLY). I use Lutris via Arch and while it doesn't help here for once, I still like it for the easy debug to chase down dependencies. I too get the out of salad memory error every single time I launch ArcheRage from Linux. Click okay and hit launch. It works every single time so far and if it doesn't this message is highly unlikely to be the source of your problem.
    I have it running on max setting while doing all kinds of other things in the background without issue. Be sure to use real drivers and chase down those dependencies and you should be good to go.
    It must be installed to it's own 64 bit prefix. I have wine set to windows 7.

    <----- for proof of work check my twitch ;)

Share This Page