What's new

Game don't start after the 'Art Loading'.


New Member
Hello, i wanted to try ArcheRage but it seems i have a issue that won't let me try it.
At first, when i finally finished the download and clicked to 'play', at the art loading, after that 4/5 letters became white, my screens became black and i needed to reboot my computer.
I tried few times but it continued.
So i re-installed it !
After pressing the Play button, the art loading screen finally work but at the end of it, the game just don't start. I can see in the task manager the Archeage.exe disappear.

So i tried to:

- Run as administrator.
- use a VPN.
- Re-install the launcher.
- Disable Windows Defender and add the file/launcher.exe/archeage.exe in exclusions from scans.
- Install DX9 from DirectX End-User Runtime Web Installer.

- updated drivers (including GPU)
- updated windows update
- Reboot PC.

- Repair the launcher after deleting the client.version (also done it with the installer directly).
- Change game location from C:\ to D:\Program Files (x86) .

And after all of that, it still doesnt work. I don't really know what to do anymore.

EDIT (03/09/23):
I just reset my PC
(from WIN11>WIN10) and it works now. I don't know if it was the only solution, but it was a solution.
In the futur, if someone have the same issue than me, you know that this is a thing you can do.
Last edited: