What's new

Game launch extremely slow

konzul

New Member
I update my windows 7 to W 8.1, now the game takes around 20 minutes to launch, after going character selection takes 5 minutes to load the game and then takes 2 minutes to load structures even after all have loaded if I summon my freighter takes 5 to 8 minutes to show the only thing I see is the name can ride it but can't move nor load packs on it, some times the game used to be lag for me but not that much, it started last week I thought was my computer so decided to format and change to W8.1 all drivers are correctly installed and updates all ok.

my pc is a AMD Phenom x4 3.0 GHZ, 8GB ram and graphic AMD radeon HD 5450 1GB, 750 GB free in hard drive.

What can I do to solve the problem?
 

Sjinderson

Well-Known Member
Staff member
Technical Assistant
Updating your OS shouldn't make the game have such a performance hit even with 8/8.1 being known as not the most friendly.
I am guessing you use a normal hard drive and so when you've updated the install has fragmented files everywhere. I would advise doing a defrag or 2 then seeing if its made a difference
 

konzul

New Member
this is only happening on Archerage, other games I launch doesn't have that problem, LOL, GW2, warframe all running good but Arche Rage, not sure if could be some optimization that requires something else to be installed or some other Microsoft visual version, I have 10-13-15-19 Microsoft visual version installed, .net framework 4.5, 4.7.2, 4.8, wish iI can have some help analyzing this cause is a pain in the *** waiting 20 minutes to launch the game.

BTW I defrag but still the same
 

Sjinderson

Well-Known Member
Staff member
Technical Assistant
ArcheAge is not like other games. ArcheAge uses one large pack that doesn't have indexing.
With that said 20 minutes to launch is far too long. Even notebooks can launch the game quicker.
The launch time is entirely dependent on drive read speeds, cpu speed and how quickly it can get through the pack file to what it wants
 
Top